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Quick Start Guide for Pro/ENGINEER Wildfire 2.0 
W. Durfee, September, 2005 

Introduction 
This is a quick start guide for the Pro/ENGINEER CAD application. It follows the 
“Beginner’s Guide to Pro/ENGINEER” written by Professor Tom Chase. The latest 
version of the Beginners Guide is dated September 6, 2001 and covers Pro/E version 
2000i2. Pro/E Wildfire was released in February, 2003 and Wildfire 2.0 released in 2004.  
Wildfire has a significantly different user interface than 2000i2 and version 2001 (the 
version between 2000i2 and Wildfire). The Quick Start Guide is updated for Wildfire 2.0, 
and was written for students in course ME2011 Introduction to Engineering at the 
University of Minnesota. Others may find it useful as a means for getting going with 
Pro/E. This document is available on-line at www.me.umn.edu/courses/me2011/proe/ 
 
The Quick Start Guide takes you through the creation of a rectangular block with a hole 
(“cubic part”), a pin that fits in the hole (“pin part”), an engineering drawing for the cubic 
part, and an assembly of the pin fitted into the hole. The assembly looks like this, 
although your colors may and should be different. 
 

 
  

Suggested strategy for completing the Quick Start Guide 
Before firing up the computer, read quickly through the Quick Start Guide to get a sense 
of what you have to do. Then fire up Pro/E and use the Guide to direct you through the 
exercise. If doing the Guide for a class assignment, read the assignment carefully to 
understand what deliverables are required.   
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Under-construction note 
The Quick Start Guide is still in the creation stage and until it is finished you will need 
some additional documentation to get you through any course assignment: 
1. “A Beginner’s Guide to Pro/ENGINEER”, available on-line at 

www.me.umn.edu/courses/me2011/proe/ 
[Guide:xx] means page xx of the Beginner’s Guide.  

2. “Pro/ENGINEER Wildfire 2.0 Tutorial” by Roger Toogood. This is the textbook used 
in ME2011. Chapter 1 of Toogood has excellent getting started information for Pro/E.  
[TG:xx] means page xx of Toogood. 

Access to Pro/E 
At the University of Minnesota, Pro/E runs on all ITLABS computers. The Pro/E section 
of the ME2011 web site has information on starting up Wildfire in ITLABS. You can 
purchase the student version of Pro/E from to run at home. See www.journeyed.com for 
purchasing information. Either Wildfire or Wildfire 2.0 is fine as they have only minor 
differences. This guide follows Wildfire 2.0  

Notation  
1. L-click means click with the left mouse button, C-click and R-click mean center and 

right button clicks.  
2. Mouse over means move the pointer over the object without clicking 
3. dddd > eeee > ffff > ...  means action dddd followed by eeee and so on. Typically this 

is a sequence of menu selections or options in a dialog box.  
4. Select means left-click.  
5.  
 
 

Startup 
To start Pro/E, see the Pro/E section on the ME2011 web site. 

www.me.umn.edu/courses/me2011/proe/ 

Create the cubic part 
Start Pro/E. The Pro/E startup screen is shown below, although you may have some 
variation in the embedded browser window 
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On the navigator screen with the folders, right click on your home directory folder, then 
Make New to create a new folder called Proe, and then create another folder inside called 
Guide (or whatever other name you want to give this assignment). It is good practice to 
have a separate folder for each Pro/E assignment. If you are working in ITlabs, make 
your directory in the drive labeled with your username. If you make it under My 
Documents, the files won’t be there when you login on another machine.  
 
Right click on your new folder, then select 
Make Working Directory so that all files for this 
session go into your new folder. (Or File > Set 
Working Directory, then select a directory) 
 
To start a new part, File > New. You’ll get the 
dialog box shown at the right. Select Part, than 
in the name box enter “cubic”. Keep the Use 
default template option checked. Hit OK. 
 
A set of default datum planes will appear, 
marked FRONT, TOP, and RIGHT as shown in 
the next figure. Note that as you mouse over the 
planes without clicking, they will turn blue to 
indicate they are highlighted and ready to select. 
Depending on the speed of your computer, you 

Navigator 
Embedded browser 

Top toolbar 
Navigator 
controls 

Main menubar 
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may have to hold the 
mouse over the 
feature before it 
turns blue. When a 
feature is selected 
with a left mouse 
click, it will turn 
red. Get in the habit 
of whenever you are 
about to click on 
something in the 
drawing window to 
select that it has 
turned blue, 
otherwise it is easy 
to select the wrong 
item.  
 

From the far right tool bar select the Extrude tool button . You are telling Pro/E 
that you want to extrude a part whose cross-section you will sketch. 
 
The Extrusion dashboard will appear across the bottom of the screen 

 
 
Select the Placement button (over on the left) from the Extrusion dashboard, then Define. 
The Sketch dialog box will pop up at the top right.  
 
Hover the mouse over the FRONT datum plane until it turns blue, then left click to select. 
This lets Pro/E know you want to sketch the cross-section of the extrusion on the front 
datum plane.  
 
Click the Sketch button in the Sketch dialog box.  
 
The References dialog box will pop up.  Note that the Reference status is “Fully Placed”. 
Click Close.  
 
You are now in the sketcher, ready to create the cross section of your part. The sketcher 
has a drawing window and a collection of tools as shown below  
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Draw the rectangular cross section of the cubic part using the line tool.   from the 
right tool bar. Left click at the origin to place the first corner, then move right along the 

horizontal axis and left click 
to place the second corner, 
then up and click to create 
corner three, then back to the 
vertical axis to place corner 
four, then finally back to the 
origin and left click. Move 
away, then center click to end.  
 
Notice that as you draw, 

letters may flash up near the lines. This is the Pro/E Intent Manager working in the 
background, guessing what you are intending to create. For example, the ‘H’ indicates 
that the line will be constrained to be horizontal. If ‘L1’ appears in two places, the Intent 
Manager will constrain the two dimensions to be equal. The Intent Manager is convenient 
and frustrating at the same time. Learn not to fight it because generally its guesses are 
pretty good. The trick is to draw an exaggerated shape and then fix later by fine-tuning 
the dimensions. For example if you want to draw a line that is three degrees from vertical, 
draw it well off vertical, then later go back in and dimension the three degrees. If you try 
and draw it actually at three degrees, the Intent Manager will snap the line to vertical. For 

Drawing 
window 

Drawing 
tools 
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the cubic cross section, draw the width wider than the height or else the Intent Manager 
will assume you are trying to draw a square. 
 
To summarize, L-click to set the points. (No dragging with the button held down.) After 
closing the rectangle, pull the cursor away from the last point and C-click to end.  
 

Click the Select tool  from the right toolbar.  
 
The dimensions of the rectangle will appear in light gray. Double click on any dimension 
to change. The width should be 8.00 and the height 4.00.  The drawing will regenerate to 
the new dimensions after each entry.  
 

When the dimensions are correct, click the Accept button   (the checkmark) at the 
bottom of the right toolbar to complete the sketch.  
 
Back in the Extrude dashboard at the bottom left, enter 4.0, the depth of the part, into the 
text box just to the right of the Depth Specifications Options.  

 
 

Click the Accept button  (the check mark) at the far right of the dashboard to finish 
the extrude process.   
 
Your part is complete. It is a rectangular block 8.00 wide by 4.00 tall by 4.00 deep.  
 
Save your part by File > Save. At the bottom of the screen, look for the message asking 
you for the filename. Accept the suggested name.  
 
Hint: If you find yourself clicking and clicking with nothing happening, look at the 
bottom of the screen for a msg. Pro/E may be asking you for something.  
 

Tips 
In the sketcher, you can change dimensions by choosing 

the select tool  (the arrow at the top of the right toolbar) 
simply by double-clicking on the number. You can also 
move dimensions around by dragging.  
 
Another way to change dimensions is with  the Modify 

Dimensions tool   This is handy if you have to change 



Quick Start Guide to Pro/E Page 7 of 21 

a number of dimensions. Select the tool then click on all the dimensions you want to 
modify. Uncheck Regenerate so that you can make all the dimension changes before the 
part regenerates. Click the check mark in the Modify Dimensions dialog box to finish the 
changes and regenerate the part.  
 

The sketcher has an undo command. Edit > undo, or use the Undo button  along the 
top toolbar.  

Viewing the part 
Turn off the display of datum planes, datum axes, datum points, and coordinate systems 

by clicking on their buttons along the top toolbar . 
 
Spin by holding down the center button and moving the mouse.  
 
Zoom in and out by holding down the CTRL key and the center button and moving the 
mouse up and down. Or, if you have a scroll wheel on your mouse, use that to zoom.  
 
Pan by holding down the SHIFT key and the middle button while moving the mouse.  
 
Try out wireframe, hidden line, no hidden line, and shaded views by clicking their their 
buttons along the top toolbar [TG:1-7, Fig. 3]. Understand what each does.  
 

Try out the Repaint , Refit , and Reorient View  buttons along the top 
toolbar [TG:1-7, Fig. 3]. 
 
Press CTRL+D to orient the part to the standard orientation.  

Try each of the views under the Saved View List, again a button on the top toolbar . 
In Default view, your part should look like this. 
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Turn the Spin Center off using its button on the top toolbar.  Try spinning the object 
with the center mouse button. You’ll notice that with the Spin Center on, the part spins 
around the Spin Center. With the Spin Center off, the part spins around the pointer. This 
is very useful when you are zoomed way in to examine  detail on a part with fine 
features.  
 

To really zoom in, select the Zoom in tool from the top toolbar  . Click to define the 
top left and click again for the lower right of the zoom rectangle. Try zooming way in on 
a corner.  
 

To get your part back to its normal state, click the Refit button , or hit Ctrl-D. 
 
If you wish, scan the Toogood tutorial pages 1-5 to 1-22 (optional) where you can find 
much more detail on all the top toolbar buttons.  
 
Admire your work.  

Selection  basics 
With your completed cubic part on the screen, place in the 
default view. Hover the mouse over the part and notice how it 
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gets highlighted. Click to select and the part outline will turn red. Now take a look at the 
model tree over on the left.  (For a sample model tree for a complex part, see [TG:1-23, 
Fig. 15]). The model tree lists all of the features of your part. Notice how the Protrusion 
feature is highlighted indicating you have selected the base part. You can also select a 
feature by clicking directly on the model tree. This is very handy for complex parts with 
many overlapping features.  
 

Turn on the viewing of datum planes (top toolbar ) and click items on the model tree 
noticing what gets selected.  
 
Sometimes you will have to select surfaces or edges or vertexes on a model. Here the 
picking is a little more tricky.  
 
Look down at the Selection Filter at the bottom right of the screen 

 . It is set to Smart which means Pro/E is doing the best it can 
figuring out whether you are trying to select the whole part or a surface which you click 
on the object.  
 
Change the Selection Filter to Geometry using its pull down menu. Now hover the mouse 
over the various surfaces on your cube and see which get highlighted. Select some 
surfaces and see if they turn red. Do the same thing by hovering over edges and vertexes 
than selecting.  
 
Let’s say you want to select the bottom surface that is hidden. You could spin the part 
around and select. Or, with the part in default view, hold the mouse over where you think 
the bottom surface is and right click. The bottom should highlight in blue, ready for a left 
click to select. Try it.  
 
This takes a bit of getting used to, so don’t worry if it isn’t too clear just yet.  
 
Change the Selection Filter back to Smart.  

Modifying part dimensions.  
Select the part by left clicking. You know you have the whole part selected when its 
outline turns red.  
 
Hint: Use the model tree for selection whenever possible 
 
Right click, then select Edit from the pop up menu. The three dimensions that define your 
part should appear in yellow. The placement of dimensions has nothing to do with where 
the dimensions are placed in the drawings you will be making shortly.  
 
Double click on the 8.00 dimension and change to 2. Notice that while the length of the 
dimension line changed, the part did not. That’s because Pro/E is waiting for you to 
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explicitly regenerate the part after making changes. Real-time regeneration would not 
work because things would get too busy when making many changes on a complex part.  
 
Regenerate your part by Edit > Regenerate, by hitting Ctrl-G, or by clicking the 

Regenerate button on the top toolbar .  
 
Get the dimensions to appear again (Select the feature, right click, Edit). Change the 2.00 
back to 8. Regenerate 
 
Save your part.  
 
There is no Undo command after a part regeneration. 
Once you have regenerated, that’s it. If you part gets 
totally messed up, and it is a simple part. Sometimes it is 
better to cut your losses, delete the part and start from 
scratch.  

Advanced modifications (you can skip this 
section) 
Sometimes the things you need to modify require going 
back into sketcher. For this, select the feature you need to 
modify (either by selecting on the part, or by selecting 
from the model tree). Right click > Edit Definition. From 
the dashboard at the bottom, select Placement > Edit > 
Sketch which will take you back into the sketcher where 
you were before. When done, select OK from the Section 
dialog box.  

Changing the color of your part 
You can have your part be whatever color you wish. 
Here’s how.  
 
View > Color and appearances. The Appearance Editor 
window will pop up [TG:9-22; Fig. 38]. Click the large 
“+” at the top right to add a new color. Towards the 
bottom, select the Basic tab, then click on the color. This 
brings up the Color Editor from which you can select a 
color via a color wheel or by setting RGB values. Find 
the color you like then close the color editor. For RGB 
values of basic colors see the table at [TG:9-24]. 
 
You can add as many colors to the palate as you like and 
you can name your custom colors. There are a few 
default colors already entered.  Once you have your 
collection of colors in the Appearance Editor, you assign 
colors to parts.  
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Confirm that the Assignment pull down list in the Appearance Editor is set to Parts. 
Select the part you want to color, then select Apply in the Appearance Editor. Your part 
should now be the new color. If you don’t like it, you can edit your color using the Color 
Editor, or the slider bars on the Properties section of the Appearance Editor.  
 
Coloring is an art. Pick colors that are pleasing to the eye, but at the same time show off 
your part or assembly to its best advantage. Color may look different on printouts than 
the monitor. Often, brightening up the color with the Intensity slider helps. Experiment. 
Find something you like. (Hint: For school assignments, do not turn in anything with 
marbled or wood-grain coloring.) 
 
Close the Appearance Editor and save your part. (Hint: Center-click is the same as hitting 
the check-mark the filename confirmation window that comes up at the bottom.) 
 

Printing your part 
To print a part, see the “How to print a Pro/E drawing in ITlabs” document posted at 
www.me.umn.edu/courses/me2011/proe/ 
 
For ME2011, you will need a black and white hidden line view of your part, without the 
hole. See the assignment for details.  
 

Adding a hole 
Drill a hole in the front face of the cube that goes all the way through. The hole should be 
2.00 over from the left side, 2.00 up from the bottom and 0.75 in diameter. Here is how to 
do it.  
 
Place the part in default orientation (CTRL+D) 
 
Change the Selection filter at the bottom right to Geometry. 

 
 

Pick the hole tool from the right tool bar button .  
 
The hole dashboard will open at the bottom. 

 
 
Carefully select the front surface of the cube, clicking about where you want the center 
of the hole to be located. Be sure to select the front of the cube, not the top. To select 
carefully, hover the mouse until the proper surface is outlined in blue, then left-click 
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where you want the hole. Sometimes determining which is the front surface is hard 
because your eye plays tricks on you. Switching between shaded, hidden line and wire-
frame views can help. Do not select the FRONT datum plane, but instead the front 
surface of the hole. Another way to guarantee you are on the front is to orient the part in 

FRONT view using the Saved view list button , and then click right on the front 
surface for placing the hole.  
 
Are you on the front surface?  
 
You’ll see a tentative hole colored yellow on your part. Pro/E has made its best guess on 
what you wanted and made the hole for you.  
 

 
 
Now you must add the details. Read [TG:3-5 to 3-6] for an overview of hole details.  
 
Zoom in a bit so you can see what’s going on.  
 
Find the four drag handles mentioned in [TG:3-6]. Try moving the center of the hole, 
changing its depth, and changing its diameter by moving the handles.  
 
There are two location handles that must be ties to two of the side surfaces of the cube 
part to precisely locate the hole with respect to its surfaces. Drag one handle down until 
the bottom surface lights up, then let go. Drag the other over until it is tied to the left 
surface. When setting these location handles, make sure they are tied to surfaces rather 
than to edges. One way of ensuring this is to select the Selection filter at the bottom right 
to Surface. The reason you always want to dimension to surfaces because edges can 
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change if rounded or chamfered. Sometimes placing the references is easier if you orient 
the part to a front view. (From the top tool bar, Saved View list button  > FRONT).  
 
Once the reference handles are set, double click on the numbers. Set the diameter to 0.75, 
the distance from the bottom to 2.00, and the distance from the left to 2.00.  

 
 
Change the hole type to Thru all using the Depth Spec button on the hole dashboard 

.  The thru all icon is the one that looks like the hole goes through everything. 
[TG:3-3, Fig. 4] shows the various hole options.  
 
Click the check mark at the far right of the hole dashboard to complete the hole.  
 
Spin, and zoom to admire your work.  
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Is your hole in the wrong place? Select the hole on the model tree, then R-click and pick 
Edit from the pop up menu. Dimensions can be changed by double-clicking on the 
numbers. To change which surfaces the hole is referenced to, select the hole > R-click > 
Edit definition. This takes you back into the dashboard where you can change anything 
and everything about the hole including the reference handles or the drilling surface.  
 
Save your work.  
 
File > Close window to shut down the cubic part window. You can always bring it back 
with File > Open.  

Creating the pin 
Quickly skim through Section 8 of [Guide]. Here’s how to do the same in Wildfire.  
 
File > New > Part > Name = “pin” > OK 
 
The default datum planes will appear. If not, turn them on from the top toolbar.  
 
Select the Revolve tool from the right tool bar [TG:2-5,Fig. 8]. You are telling Pro/E that 
you are going to sketch a cross section and then revolve that section about a centerline to 
create a solid part.  
 
The revolve dashboard will appear at the bottom of the screen.  
 
Select Placement, then Define, then the FRONT plane to tell Pro/E you are sketching the 
cross section on the front plane.  
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Click Sketch on the  Section dialog box and Close on the References dialog box.  
 
You are now in sketcher, ready to create the cross section of your part. To be accurate, 
you will be sketching one half of the cross section because what you sketch will be 
revolved about a center line to create the solid part.  
 
Now follow [Guide] from the middle of page 21 (starting with “Revolved sections 
require definition…”, all the way to page 23, middle of column 1, “The sketch is 
completed by clicking the Done (Accept or checkmark) tool.” 
 
Some common errors are: (1) not creating a center line; (2) dimensioning radii rather than 
diameters, (3) not changing the dimensioning scheme per specifications in [Guide: Fig. 
27].  
 
Hint: To dimension the diameter, select the Dimension tool as described in [Guide], then 
L-click on the outside, L-click on the center line, L-click again on the outside, then C-
click to place the dimension.  
 
When you click the Accept button, you will be back in dashboard mode. If all went well, 
you will have some kind of pin on the screen. If things look good, click the checkmark 
button at the bottom right to create the part.  
 
To edit the dimensions of the pin, R-click the  Protrusion feature from the model tree  > 
Edit. All the relevant dimensions will appear in yellow. Double click on each to 
dimension according to [Guide:24, Fig. 27].  
 
After all the dimensions are correct, regenerate the part (top toolbar).  
 
Spin, zoom, and admire your work. (If you have one, try using the mouse scroll wheel for 
zooming. Also, turn off the Spin Center (top tool bar) and try zooming in and spinning 
and around the underside of the cap.) 
 
CTRL+D restores the default view.  
 
Save your part.  
 
Color the pin  something else if you like.  
 
Save your part.  

Creating the assembly 
Skim Section 9 of [Guide], then skim pages 9-5 to 9-8 of [TG], then follow the steps 
outlined here to create the assembly.  
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Section 9 the Guide correctly states that the proper way to create assemblies is to 
constrain all of the objects to datum planes rather than to each other. For assemblies of 
ten or fewer parts, however, it is much simpler to assemble parts by referencing features 
on other parts. This note will take you through the same steps as Section 9 of the Guide, 
but with a simpler process and tailored for Wildfire.  
 
The Pro/E assembly tools allow you to join parts into a final product. The process used is 
to bring the base part into the assembly (the cubic for this tutorial) with no constraints. 
The next part (the pin) is then brought into the assembly. Next, you define two or three 
constraints that fix the position and orientation of the new part to the existing part. For 
the pin part, only two constraints are needed. For the first constraint you will align the 
axis of the pin with the axis of the hole on the cubic. For the second constraint you will 
mate the front surface of the cubic to the underside of the head of the pin. You will use 
the mate offset constraint so that you can specify any distance you want between those 
two surfaces thus allowing the pin to set flat against the block (offset = 0) or to be an 
arbitrary distance away. Because the pin has circular symmetry, you don't care about how 
it is rotated so no third constraint is needed.  
 
Step 1: Start the assembly 
File > New > Assembly > [name the assembly "pin_cube" or anything convenient] > OK 
 
A set of default datum assembly planes will appear. Turn off the display of datum planes, 
and turn on the display of datum axes (the top toolbar [TG:1-7, Fig. 3]).  
 
Step 2: Bring the cubic part into the assembly 
Select the Add component tool on the right toolbar [TG:9-9, bottom]. Select the cubic 
part from the file menu.  
 
The block will appear in the assembly window and a Component Placement dialog box 
will appear on the right. In the dialog box, select OK because we are not constraining the 
block to anything.  
 
Step 3: Bring the pin into the assembly 
Click the Add component button and select pin.prt from the file menu.  
 
The pin will appear in the assembly window. If you don't like where it is, Hit the Move 
tab in the Component Placement box, L-click to drag. L-click again to drop. Note that 
this type of move is purely for the convenience of the user and has nothing to do with 
how the parts are constrained in the assembly. After moving, click the Place tab in the 
Component Placement box.  
 
Step 4: Constrain the pin to the block 
Constraint #1: Note that the Constraints box has one constraint listed as being in the 
Defining state [TG:9-10,  Fig. 19]. This means the system is waiting for you to enter the 
first constraint.  
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Change the constraint type from Automatic to Align using the Type drop down menu.  
Note that the message area at the bottom of the screen is telling you to select an aligning 
surface or axis on one part.  
 
Hover the mouse over the dashed line axis of the hole (did you turn on the display of 
axes?) making sure it turns blue before selecting.  Note that the message area is now 
instructing you to select another axis for aligning.  
 
Hover the mouse over the dashed line axis of the pin, then select.   
 
The pin is now brought into alignment with the hole. In fact, it may have moved right 
inside the block and perhaps you can't see it in shaded view. Switch to hidden line view 
to locate the pin. Note that when to try to move the pin using the Move tab, it will only 
move axially because of the align constraint.  
 
Constraint #2: For this constraint type, select Mate from the Type menu. Select the front 
face of the block and the underside of the head of the pin as the two mating surfaces. 
Before L-clicking to select, make sure the correct entity is highlighted in blue. For 
additional assurance, read the text at the very bottom left which indicates the current 
highlight.  To select the underside of the pin head,  zoom in so that the pin head fills the 
screen and rotate so you can see the underside. Make sure the desired surface is 
highlighted before selecting.   
 
An entry box will appear in the bottom message area where you can enter the offset 
distance between these two surfaces. Enter 1.0, then click the arrow or hit the Enter key 
or C-click to accept.1  
 
The pin is now fully constrained. Hit OK in the Component Placement box.  
 
Save the assembly.  
 
Turn off the datum axes, shade the assembly, then zoom and spin to admire your work.  
 
Sometimes the preselection highlighting can get annoying when spinning a part. To 
temporarily turn it off, Edit > Select > Preferences and uncheck the Preselection 
highlighting box.  
 
Changing offset distance 
To change the distance between the head of the pin and the block, double click on the 
pin. Or, select the pin from the model tree, R-click > Edit. The offset dimension will 
appear in yellow.  
 
Double click the dimension and change to 2.0.  
 
Regenerate the part. (Edit > Regenerate, or Ctrl-G) 
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Change the offset to 0.25 and regenerate. You are done. Save your assembly.  
 
Close the assembly. File > Close window.  
 
You now are an expert at assembly. For most parts, you only need to use the Align and 
Mate constraints even though many other options are available. Parts without circular 
symmetry require three constraints. If you always think about design intent when you set 
constraints, your assemblies will be in good shape.  

Creating drawings 
Skim through Section 10 of [Guide] and page 8-1 of [TG].  Here’s how to do the [Guide] 
tasks in Wildfire.  
 
Create a new drawing. File > New > Drawing. Give it a convenient name, for example 
“cubic_dwg”, then hit OK.  
 
In the New Drawing dialog, Use the Browse button to find the cubic part and make it the 
default model.  
 
Under Template, select the c_drawing template. This creates a C size drawing that will be 
latter be printed on 8.5 x 11 inch paper. This combination works well for most parts and 
results in an appropriate font size for dimensions and labels.  
 
Hit OK to close the New Drawing box.  
 
Your cube part should appear in the drawing, with properly placed front, top and right 
side views.  
 
At the bottom left of the drawing, find the SCALE 0.500 mark which indicates that the 
work is being shown in a 0.5:1 scale. Double click on the 0.500 and change to 1.00 in the 
text box at the bottom. In general you want your parts to fill the paper, leaving room for 
dimensions and comments.  
 
Generally, the default positioning of the views needs some tweaking. Turn off the Lock 
View button in the top toolbar [TG:8-6, bottom].  
 
L-click a view and drag. Note that Pro/E constrains the motion to maintain alignment 
between views.  
 
Move the views to match [Guide:28, Fig. 30]. Relock the views with the Lock View 
button.  
 
Add a 3-D view of the cube to the upper right corner. Click the Add View button on the 
top toolbar [TG:8-5, middle]. (Or, Insert > Drawing View > General). 
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On the drawing, left click in the top right quadrant where you want the 3-D view to 
appear. See [Guide: Fig. 30] for the location.  The Drawing View dialog box will appear.  
 
 In the Drawing View dialog box select  Scale > Custom Scale and enter 0.5. Select OK 
to close.  
 
Double click the new view. From the Drawing View dialog box select  Scale > Custom 
Scale and enter 1.0, then Apply and see what happens. Change back to a scale of 0.500.  
Select OK to close the Drawing View box.  
 
Admire, then save your drawing.  
 
Now that the views are placed, you can add the dimensions.  
 
View > Show and Erase… (or select the Show/Erase button [TG:8-7, middle]).  
 
Hover the mouse over each button in the Show/Erase window to see what each does.  
 
Select the Dimension (top left ) button. Select Show By Part. Select the Preview tab and 
enable With Preview. Select Show All, then Yes to the confirmation.  
 
All of the dimensions of your part will appear on the drawing, with Pro/E’s best guess as 
to view and location.  
 
In the Show/Erase box, Accept All > Close.  
 
A designer can change dimension values in drawing mode and any changes will ripple 
through the relevant parts and assemblies because they are all stored in the same 
database. For example, Select Edit > Value, then click on the hole diameter dimension. 
Change to 2.0. Regenerate the part. If you wish, open the cubic part (File > Open) and 
confirm that the part has indeed changed. Change the hole back to 0.75. Regenerate.  
 
You may not like where the dimensions are placed, and for this assignment, you need to 
match what you see in [Guide: Fig. 30]. To move the dimensions, do the following.  L-
click to select a dimension, then L-press and drag to move the dimension. Don’t worry if 
the yellow extension lines touch the part; Pro/E will clean this up at printout time.  
 
Here is how to move a dimension from one view to another. L-click the dimension to 
select (turns red). R-click and select Move Item to View from the pop up menu. L-click 
the view where you want the dimension to go.  
 
If you like your arrows on the outside (useful for short dimensions), select the dimension, 
R-click and select Flip Arrows from the pop up.  
 
Hint: You can get Pro/E to clean up the dimensions if things are looking a little crowded 
by doing Edit > Cleanup > Dimensions. Press the left button and drag the mouse to define 
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a selection box around the entire drawing. Click OK on the Select box. Click Apply, then 
Close on the Clean Dimensions box. The gray lines that appear are Snap Lines that 
dimensions are snapped to when cleaned. They won’t appear on printouts. If you don’t 
like them now, Edit > Delete > select the snap line. Or Tools > Environment, then 
deselect display of Snap Lines. View > Repaint (or CTRL+R) to repaint the screen so 
you can see the changes. For a complex drawing, use the auto cleanup to get things 
somewhat in shape, then go back and fine tune so the dimensions are just where you want 
them. For this assignment, auto cleanup is not needed.  
 
All drawings need a title, name and date. Here is how to add a text note to your drawing. 
Select Insert > Note. On the NOTE TYPES menu, select No Leader > Enter > Horizontal 
> Standard > Default > Make Note.  L-click on the drawing where the note should go, in 
this case the lower right. Enter the desired text in the text box at the bottom of the screen. 
All lettering should be in block capitals. The first line should have the title of the drawing 
(CUBIC), the second line your name and the third line the date. The Text Symbol box 
lets you enter a variety of symbols useful for CAD drawings. Pressing Enter will take you 
to the next line. Press Enter twice (or the check mark to the right of the entry box) to 
close the note, then Done/Return on the NOTE TYPES menu. ([TG:8-12] has more on 
notes.).  
 
To move the note: L-click the note to select, then L-press to drag to a new location.  
 
Double click the note to edit. In the Note Properties box, the Text Style tab lets you 
change the font or text size. Use the Preview button to see your changes.  
 
To add axis lines to the holes: View > Show and Erase… (or select the Show/Erase 
button on the top toolbar). In the Show/Erase box, select the Axes button (….A1), then 
Show By Part, then Show All. Answer Yes to the confirmation and dashed axis lines will 
appear.  
 
Make your drawing as close to [Guide:28, Fig. 30] as you can, adding your name and the 
date below the CUBIC title.  
 
Save, then admire your drawing.  
 
See [Guide:31] for information on printing. Pay attention to the instructions on how to 
print out on 8.5 x 11 (A size) paper.  
 
Warning: Printing instructions vary depending on whether you are on a Unix or Windows 
machine, whether you are at home or in one of the ITLABS. If in doubt, ask a classmate, 
the computer consultant or a course staff member.  

All done 
Congratulations. You have completed the tutorial and are now licensed to add 
“Pro/ENGINEER” to your resume. If you are taking ME2011, review the assignment 
instructions carefully to determine what to turn in.  
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Other things you can do with Pro/E 
You can send your part, drawing, and assembly files by email. Bring up the part you want 
to send, then hit the Send email button on the top toolbar [TG:1-7, Fig. 3]. If you zip 
while in assembly view, all the parts will be included. This is a great way to 
collaboratively work on a team project. The email will include info on the free Pro/E 
parts viewer so that those without access to Pro/E can see your parts.  
 
If you like fun, but completely useless features, try this. Get a part up on the screen. Turn 
the View Mode button on (top toolbar [TG:1-7, Fig. 3]. Right click in the main graphics 
area and select Velocity from the pop up menu. Press on the part with the center button. 
The further away you move the mouse while pressing, the faster the object will spin. This 
will really impress your friends! 
 
The Pro/E startup screen has links to online tutorials you can run.  
 
Consider going through all of Chapter 1 in the Toogood tutorial. The part files are on the 
CD that comes with the text. You can also go through the on-line tutorial that is on the 
CD. 
 


